Salut ! Ma puteti ajuta si pe mine va rog la acesta problema ? lucrez la sololearn c# si am intampinat aceasta problema :
The program you are given takes 5 numbers as input and stores them in an array.
Complete the program to go through the array and output the the sum of even numbers.
Sample Input
10
890
15
3699
14
Sample Output
914
Hint
An integer is even if it is divisible by two, so it means that n number is even if n%2 equals 0.
Anexe:
Răspunsuri la întrebare
Răspuns de
1
using System;
using System.Collections.Generic;
using System.Diagnostics;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace SoloLearn
{
class Program
{
static void Main(string[] args)
{
int[] numbers = new int[5];
int count = 0;
while (count <5)
{
numbers[count] = Convert.ToInt32(Console.ReadLine());
count++;
}
int sum = 0;
foreach (int number in numbers)
{
if (number % 2 == 0)
{
sum += number;
}
}
Console.WriteLine(sum);
}
}
}
Alte întrebări interesante
Matematică,
8 ani în urmă
Studii sociale,
8 ani în urmă
Matematică,
8 ani în urmă
Limba română,
8 ani în urmă
Matematică,
8 ani în urmă
Engleza,
8 ani în urmă